< SAGE Updates and Important Announcements! - BCN

SAGE Updates and Important Announcements!

Sage 200 License Expiry & TLS Important Update: 

 

Deadlines are drawing closer to an end for those customers using Sage 200 2013 up to and including Sage 200 2019 (all versions that use the Sage License operate under the TLS 1.0 protocol). The TLS is a security protocol required for a variety of services, including the Sage License Service, that enables products to communicate securely.

Importantly, however, TLS is not a protocol provided by Sage.

As this security protocol is now retired, with no future security updates scheduled, it presents risks to customers if they continue to use it. To increase security and remove the risk, Sage has decided to retire the use of this protocol.

 

What has changed in recent months? 

 

The deadline which all customers need to upgrade to the newest versions of Sage 200 which operate under the new license service is now the 30th of September 2022. The previous date that Sage had communicated was 30th September 2023.

 

Why have they decided to change dates? 

 

Sage’s recent monitoring has identified that the potential risk of using the protocol has increased, and would therefore be inappropriate for Sage to retain the original deadline of the 30th September 2023.

 

What does this mean for you? 

 

Versions that Sage originally thought were “safe” need to do one of two things prior to 30th September 2022:

 

If you are running Sage 2017.02 (Spring 2018), Sage 2018.00 (Summer 2018), Sage 2018.01 (Winter 2018), or Sage 2018.02 (Spring 2019); Sage will be shortly releasing a Patch that will need to be applied prior to the 30th September 2022.

 

Or,

 

Upgrade to the latest version. 

 

As always, our Sage experts are on-hand to discuss these options with you to find the best solution for your business. Don’t leave it too late, it is important for your security that we speak about this and schedule the work with you.

For customers of a Sage 200 Historical License, it is also important that we speak to each other about the long-term plan for Sage 200 in your business.

 

Sage 200, Sage CRM, and Microsoft Internet Explorer

 

Technology continues to change at a pace, and that includes how Sage works in tandem with other software, including operating systems and web browsers. To this end, we wanted to ensure that you are fully aware of the Microsoft announcement which states:

 

“Internet Explorer (IE) 11 is the last major version of Internet Explorer. Starting June 15, 2022, the Internet Explorer 11 desktop application will no longer be supported on certain versions of Windows 10*”.

 

What does this mean for you? 

 

Whilst Sage 200 and Sage CRM solutions will require IE11 in order to continue to work, certain organisations, such as financial institutions, may reject their use, due to the potential security risk of IE11.

 

What should you do? 

 

If you are using Internet Explorer 11 in your business be sure to contact us prior to making any changes.

 

BCN Group are here to offer you expert advice and give you clarity over what the best options are for you. Speak to one of our team today for insights into the best practices follow these changes.